Categories

Downloads

 

Kmax 11.x Downloads

 

Kmax 11.16 is the latest release of the Kmax data acquisition and data analysis application software.

In version 11.16, the JDK (version 16) and JavaFX (version 16) are included in the Kmax application bundle.  JDK version 16 introduces a new class version (60), so Kmax external classes and drivers that were compiled with java class versions earlier than 60 must be recompiled with JDK version 16 or later in order to be compatible with Kmax version 11.16.

Kmax 11.16 does not require that Java or Javafx are installed on the user’s computer since private versions are included in the Kmax application bundles.

Kmax 11.16 requires : Mac OS X 10.15 or above; Windows 10 or above; and Linux Fedora 33 or above (other Linux flavors may also work).  Operating systems must be 64-bit.

 

 

Kmax 11.4 is a legacy release of the Kmax family of data acquisition and data analysis application software.  It updates the Kmax environment to be compatible with the latest releases of the Windows, MacOS and Linux operating systems. Kmax 11 requires the Java JDK, JavaFX SDK, and a 64-bit operating system.

 

Kmax 11.3 is the legacy release of the Kmax data acquisition and data analysis application software.  Version 11.3 requires JDK version 15 and JavaFX version 15.  JDK version 15 introduces a new class version (59), so Kmax external classes and drivers that were compiled with java class versions earlier than 59 must be recompiled with JDK version 15.0.1 or later in order to be compatible with Kmax version 11.3.

Kmax 11.3 requires : Java JDK version 15, or above; JavaFX version 15, or above; Mac OS X 10.15 or above; Windows10 or above; Linux Fedora 33 or above (other Linux flavors may also work).  Operating systems must be 64-bit.

 

Kmax 11.2 is the legacy release of the Kmax family of data acquisition and data analysis application software. It updates the Kmax environment to be compatible with the latest releases of the Windows, MacOS and Linux operating systems.  Kmax 11.2 requires : Java JDK version 15, or above; JavaFX version 15, or above; Mac OS X 10.15 or above; Windows10 or above; Linux Fedora 33 or above (other Linux flavors may also work).  Operating systems must be 64-bit.

Kmax 10.x Downloads

Kmax 10.2 is the legacy release of the Kmax data acquisition and data analysis applicahttp://www.sparrowcorp.com/wp-cohttp://www.sparrowcorp.com/wp-content/uploads/2012/10/Kmax9.5.ziption software.  It updates the Kmax application to be compatible with the latest releases of 64-bit Windows, Macintosh, and Linux operating systems.  It updates the developer examples, CAMAC and VME driver extensions and the toolsheet examples.  It does not run on 32-bit systems.

Kmax 9.5 Downloads

Kmax 9.5 is a legacy release of the Kmax family of data acquisition and data analysis application software.It updates the Kmax application to be compatible with the rectnt releases of the Windows, Macintosh and Linux operating systems.  It adds developer support for external classes, drivers, stand-alone Kmax tools.

Kmax 8.2 Downloads

Kmax 8.2 is a legacy release of the Kmax family of data acquisition and data analysis application software.It combines and expands the feature sets of previous versions and is designed to run on Windows, Mac OS X, and Linux based computers.  Kmax 8.x requires a Java SDK be installed on the computer system, version J2SE 5.0 or higher.The full SDK is required.  Kmax 8.x does not support Command Sequence Language (CSL).  All toolsheets that use CSL must be ported to Java.  Kmax 8.x supports a new driver model.  Drivers that were shipped and/or developed for earlier versions of Kmax will not work Kmax 8.x.  The Kmax distribution comes with new drivers already installed.                   

Kmax 7.4 Downloads

Kmax 7.4.4 is a legacy release of the Kmax family of data acquisition and data analysis application software maintained for users who want to continue to use Command Sequence Language (CSL).It runs on Windows, Mac OS X, and Linux based computers.Kmax requires a Java SDK be installed on the computer system, version 1.4 or higher. The full SDK is required.
 

User Extensions Downloads

The packages posted on the page contain tools, toolsheets, drivers, components, and java classes that were contributed by members of the Kmax user community.  The packages have not been tested by Sparrow Corporation and Sparrow does not warrant them in any way.  Sparrow Corporation does not provide technical support for the items in the packages listed.  Download and use these items at your own risk.  If you would like to share an item with the Kmax user community please send the item and descriptive information to: info@sparrowcorp.com